new –codecoverage parameter in package build not showing up

I’m running a package build on our packages to get the –codecoverage parameter like so:

sfdx force:package:version:create -p myPackage -w 100 -x -v DevHub  --json --codecoverage

This runs, and returns

Request in progress. Sleeping 30 seconds. Will wait a total of 6000 more seconds before 
timing out. Current Status='Initializing'
Request in progress. Sleeping 30 seconds. Will wait a total of 5970 more seconds before 
timing out. Current Status='Initializing'
Request in progress. Sleeping 30 seconds. Will wait a total of 5940 more seconds before 
 timing out. Current Status='Verifying features and settings'
Request in progress. Sleeping 30 seconds. Will wait a total of 5910 more seconds before 
timing out. Current Status='Verifying metadata'
Request in progress. Sleeping 30 seconds. Will wait a total of 5880 more seconds before 
timing out. Current Status='Verifying metadata'
Request in progress. Sleeping 30 seconds. Will wait a total of 5850 more seconds before t. 
timing out. Current Status='Verifying metadata'
Request in progress. Sleeping 30 seconds. Will wait a total of 5820 more seconds before 
 timing out. Current Status='Verifying metadata'
Request in progress. Sleeping 30 seconds. Will wait a total of 5790 more seconds before 
timing out. Current Status='Verifying metadata'
Request in progress. Sleeping 30 seconds. Will wait a total of 5760 more seconds before 
timing out. Current Status='Verifying metadata'
Request in progress. Sleeping 30 seconds. Will wait a total of 5730 more seconds before 
timing out. Current Status='Verifying metadata'
Request in progress. Sleeping 30 seconds. Will wait a total of 5700 more seconds before 
timing out. Current Status='Verifying metadata'
Request in progress. Sleeping 30 seconds. Will wait a total of 5670 more seconds before 
timing out. Current Status='Finalizing package version'
Request in progress. Sleeping 30 seconds. Will wait a total of 5640 more seconds before 
timing out. Current Status='Finalizing package version'
sfdx-project.json has been updated.
Successfully created the package version [08c1v000000TQdqAAG]. Subscriber Package Version 
Id: 04t1v000001YYHFAA4
Package Installation URL: https://login.salesforce.com/packaging/installPackage.apexp? 
p0=04t1v000001YYHFAA4

But codecoverage isn’t shown at all. Am I missing something here? This is when using sfdx-cli/7.73.1.

Answer

When you run the package version command with --codecoverage flag what happens is the code coverage is calculated in the backend.

You can then see the code coverage by listing the package versions for the package using the below command

sfdx force:package:version:list -p <packaged> --verbose

Attribution
Source : Link , Question Author : akarnid , Answer Author : Mohith Shrivastava

Leave a Comment