Why is deployment taking almost 40mins?

I am using the ant migration tool to deploy. The version used in the package.xml is 39. And i am not triggering any test execution, as i am deploying in a sandbox.

What can be the reason that the deployment time is so high? The number of components as per the deployment screen shows around 500. And this is not a one-off thing, its been taking this many mins for the last 1-months

All the network test like ping, tracert to the instance looks normal.

Below is the console log:
(Request ID’s altered)

deployCode:
     [echo] Performing the deploy
[sf:deploy] Request for a deploy submitted successfully.
[sf:deploy] Request ID for the current deploy task: 0dfbrekrufhwnvfAR
[sf:deploy] Waiting for server to finish processing the request...
[sf:deploy] Request Status: Pending
[sf:deploy] Request Status: InProgress
[sf:deploy] Request Status: InProgress (171/509)  -- Processing Type: Layout
[sf:deploy] Request Status: InProgress (224/509)  -- Processing Type: CustomApplication
[sf:deploy] Request Status: InProgress (224/509)  -- Processing Type: CustomApplication
[sf:deploy] Request Status: InProgress
[sf:deploy] Request Status: InProgress
[sf:deploy] Request Status: InProgress
[sf:deploy] Request Status: InProgress
[sf:deploy] Request Status: InProgress
[sf:deploy] Request Status: InProgress
[sf:deploy] Request Status: InProgress
[sf:deploy] Request Status: InProgress
[sf:deploy] Request Status: InProgress
[sf:deploy] Request Status: InProgress
[sf:deploy] Request Status: InProgress
[sf:deploy] Request Status: InProgress
[sf:deploy] Request Status: InProgress
[sf:deploy] Request Status: InProgress
[sf:deploy] Request Status: InProgress
[sf:deploy] Request Status: InProgress
[sf:deploy] Request Status: InProgress
[sf:deploy] Request Status: InProgress
[sf:deploy] Request Status: InProgress (314/509)  -- Processing Type: Profile
[sf:deploy] Request Status: InProgress (499/509)  -- Processing Type: ForecastingSettings
[sf:deploy] Request Status: Succeeded
[sf:deploy] *********** DEPLOYMENT SUCCEEDED ***********
[sf:deploy] Finished request 0dfbrekrufhwnvfAR successfully.

BUILD SUCCESSFUL
Total time: 41 minutes 53 seconds

Answer

Attribution
Source : Link , Question Author : OK999 , Answer Author : Community

Leave a Comment